Be Smart, Go Local.

How to Enable Thread and Matter Support on Sonoff ZBDongle-E

A guide detailing how to enable simultaneous Thread, Zigbee and Matter support on Sonoff’s ZBDongle model E, based on the EFR32MG21 multiprotocol SoC module.

UPDATE 14.06.2023: With Silabs Multiprotocol Add-on 2.2.0, the firmware of the dongle must be updated manually to version 4.3.0. The new addon version will fail to start with 4.2.3 firmware, see more here. Darkxst has updated his web flasher, so you can simply click update to 4.3.0 before in the dialog window.

Since the Sonoff ZBDongle-E is based on the EFR32MG21 Multiprotocol SoC chip, it’s capable of both Zigbee and Thread communication thanks to the radio of the module. However, this device is sold solely as a Zigbee dongle by the company and there is no official Thread support at the moment. Whether Sonoff intends to push an update making the device act as a Thread Border Router is unknown at this moment.

Luckily, you can flash the Sonoff ZBDongle-E version with a custom firmware and use it Home Assistant both as a Zigbee Coordinator as well as a Thread Border Router. The process is not difficult, but it does require some additional configuration and setup after you’ve flashed the device.

Thread and Matter Support Sonoff ZBDongle-E Featured

If your purpose is to simply use the device as a Zigbee coordinator, there is no need to flash anything, it ships with NCP firmware version v6.10.3 which is the latest official Zigbee firmware for the ZBDongle-E. If you want to enable Thread support as well, follow along to learn how.

Understanding the process

First and foremost, it’s important to understand what’s at stake before getting into enabling Thread support on the Sonoff ZBDongle-E. As usual with these kind of flashing processes, there is a chance you can brick your dongle beyond repair, so continue at your own risk. Note the following before you start:

  • If you are currently using the Sonoff ZBDongle-E as a Zigbee coordinator, you will have to repair all your devices after flashing the new firmware
  • Standard backup and restore methods of your Zigbee network are possible, although the chance of a successful restore once flashed are slim
  • If you have an existing ZHA integration, you will need to remove it completely than re-add it and form the network around the new multiprotocol firmware
  • If you are running a Zigbee2MQTT network, you need to stop the add-on and change the configuration to access the new multiprotocol firmware

This guide uses a Web Flasher, which will be used to install the latest RCP Multi-PAN firmware on your ZBDongle-E, which will be used to create a Zigbee network as well as provide Thread support as a Border Router.

Different firmware types

Zigbee coordinators, including the ZBDongle-E, rely on a Network Co-Processor (NCP) firmware type. The Zigbee application as well as the network protocol stack is saved on the dongle itself, which manages most of the Zigbee network. The Zigbee integration you are using, simply communicates to the dongle to send/receive commands from devices added to the network.

Recently, Remote Co-Processor (RCP) based firmware has become available for these SoC modules, allowing the Zigbee application to be offloaded to your server completely (in this case, Home Assistant), utilizing only the dongle’s radio at the hardware level.

When using the latter, the hardware capabilities of the dongle can be utilized for creating separate Zigbee and Thread networks by flashing the MultiPAN RCP firmware. This is exactly what we’re going to do.

Flashing the Sonoff ZBDongle-E

This custom firmware was developed by darkxst (Tim L) and works for Home Assistant Yellow and SkyConnect, Sonoff ZBDongle-E and EasyIot ZB-GW04 v1.1/v1.2. He also created a web flasher for the firmware, which is much easier to use than the Universal Silabs Flasher. His work is a fork from the official NabuCasa silabs firmware builder, adding support for additional hardware.

  • Download and install the latest CP210x USB drivers (Windows/Mac)
  • Plug the Sonoff ZBDongle-E to your PC
  • Identify the port number of the dongle
    • Windows: See device manager (example: COM5)
    • Linux: Check with command ls /dev/tty* (example: /dev/ttyACM0)
    • Mac: Check with command ls /dev/tty.usb* (example: /dev/tty.usbserial12345)
  • Open darkxst‘s Web Flasher

1. Click Connect under ZBDongle-E

Enabling Thread and Matter Support on the Sonoff ZBDongle-E: Connecting to Flash

2. Select the dongle from the list of ports

Enabling Thread and Matter Support on the Sonoff ZBDongle-E: Selecting Port

3. Wait for the connection to be established. Click Change Firmware

Enabling Thread and Matter Support on the Sonoff ZBDongle-E: Change Firmware

4. Select Multi-PAN (RCP) from the firmware list and click Install

Enabling Thread and Matter Support on the Sonoff ZBDongle-E: Choose Firmware

5. Wait for the firmware installation

Enabling Thread and Matter Support on the Sonoff ZBDongle-E: Installing Firmware

6. Click Continue and unplug the dongle

Enabling Thread and Matter Support on the Sonoff ZBDongle-E: Success

Once the flashing is complete, you can continue to setup your Zigbee and Thread networks in Home Assistant. Follow the guides bellow for a detailed tutorial.

Home Assistant Setup

Before you continue with the guide, make sure you are running the latest version of Home Assistant. Since Thread and Matter are relatively new integrations actively being developed, updating to the latest version will ensure minimal bugs or glitches. Keep in mind, they are both in Beta and still tagged as experimental.

Silicon Labs Multiprotocol Add-on

An crucial requirement for running both Zigbee and Thread networks on a single Sonoff ZBDongle-E is the Silicon Labs Multiprotocol Add-on. This add-on acts as a gateway between Home Assistant and the Sonoff dongle, essentially allowing you to create separate networks by utilizing the RCP Multi-PAN firmware on the dongle.

Your ZHA, Zigbee2MQTT or Thread Integrations will communicate with the Silicon Labs Multiprotocol Add-on once setup instead of directly with the dongle like before.

Thread Support Sonoff ZBDongle-E Silicon Labs Multiprotocol Installation

To install this add-on, navigate to Settings > Add-ons in Home Assistant. Search for Silicon Labs Multiprotocol and install it but don’t start it yet. Click the Configuration tab at the top and set the settings like in the image bellow:

Thread Support Sonoff ZBDongle-E Silicon Labs Multiprotocol Configuration
  • Select Sonoff ZBDongle-E
  • Baudrate 460800
  • Disable Hardware Flow Control
  • Disable Automatically Flash Firmware
  • Leave the rest as is and click save
  • Go back to the Info tab and Start the add-on

You are now ready to setup ZHA, Zigbee2MQTT or create a Thread network using the Sonoff ZBDongle-E.


Like you normally would, navigate to Settings > Devices & Services > Add Integration and search for ZHA. Select Zigbee Home Automation and follow the process flow with one important difference.

Thread Support Sonoff ZBDongle-E ZHA Setup

When it prompts you for selecting a serial port, choose socket://core-silabs-multiprotocol:9999 instead of the /dev/ttyACM0 - Sonoff dongle.

Click Submit followed by Create a new network. I would suggest not even trying to restore a backup, as it would not work. All your existing devices will be added if you restore, but none would be controllable. The ZHA Integration will now be added and you can start to pair devices like you normally would. I paired a couple of gadgets, they all work normally as they should.

Thread Support Sonoff ZBDongle-E ZHA Done


Setting up Zigbee2MQTT is similar in general, with a few small differences. First, stop the Zigbee2MQTT add-on if it’s already running. If you are installing it fresh, don’t start it before configuring it. Navigate to Settings > Add-ons > Zigbee2MQTT > Configuration tab. Under the Serial field, paste the following:

port: tcp://core-silabs-multiprotocol:9999
adapter: ezsp

Save the configuration and start the add-on. Zigbee2MQTT tells you whenever something goes wrong, so it’s a good idea to monitor the Logs while the add-on is starting. You should see a message at the end:

Zigbee2MQTT:info 2023-05-30 18:59:58: Zigbee2MQTT started!

The add-on has started successfully and you can continue to create your new Zigbee network.

If you navigate to the About tab of Zigbee2MQTT’s interface, you should see the new EZSP version:

Thread Support Sonoff ZBDongle-E Zigbee2MQTT EZSP Ver

Or you can check the coordinator listed from the Silabs Multiprotocol Add-on in Settings > Serial:

Thread Support Sonoff ZBDongle-E Zigbee2MQTT Serial

Thread Network

If you have a Thread network available, you can now add it to Home Assistant using the Sonoff ZBDongle-E as a Border Router. The Thread Integration should become automatically discovered if you’ve restarted Home Assistant, if not, navigate to Settings > Devices & Services > Add Integration > Thread. Confirm the prompt and the Integration will be added.

Thread Support Sonoff ZBDongle-E Thread Border Router

Thread-based consumer devices use one of the two Home Automation standards: Matter or HomeKit. To actually do anything with a device you need to use one of these integrations for commissioning. Please note, the Thread integration is completely in beta, so it’s a work in progress and much doesn’t work for now.

The Matter integration (and Matter Server add-on) co-ordinates provisioning and control of all Matter Wi-Fi and Thread devices. If you have a Matter certified device that’s based on the Thread protocol, you can add it to HA by using your phone and the companion app.


Enabling Thread, Zigbee and Matter support on the Sonoff ZBDongle-E is beneficial for the tinkerer’s smart home, it basically turns your Home Assistant instance into a powerful multiprotocol hub. It has the hardware capability, so why not actually use it? Credit goes to darkxst, the developer of this firmware fork and web flasher.

The Matter Integration (and Server Add-on) as well as the Thread Integration are all a work in progress. Things are going to change as we head into the second half of the year. I suggest you read this blog post from the official Home Assistant team Matter & Thread: Where we’re at to make things more clear.

The Sonoff ZBDongle-E is a good choice for a multiprotocol coordinator, you can get it on AliExpress ($20) and Amazon ($30). Australians and New Zealanders can get the ZBDongle-e from this store. The same EFR32MG21 module is also found in Home Assistant’s SkyConnect dongle as well as the Easylot ZB-GW04 dongle ($10), for which this firmware also works.

66 thoughts on “How to Enable Thread and Matter Support on Sonoff ZBDongle-E”

  1. Thank you for this! I thought holding off on the skyconnect would pay off and it looks like it will!

  2. Would love to have instructions on how to run the Silicon Labs Multiprotocol Add-on separately using docker-compose. I have a docker HA install, and hence don’t have access to addons from within HA.

    • Please, I am also interested in the instructions how to run the Silicon Labs Multiprotocol Add-on separately using docker-compose. Thanks

  3. it still is a single point of failure.

    i would instantly implement if i could use two in parallel or an active-passive setup.The zigbee dongles i tested dont properly shutdown / signoff a network once you failover to another dongle, resulting in all kinds of network errors untill you physically unplug.the passive (formerly active) dongle.

  4. So… having had this working yesterday, it not longer is… and I’m confused, as nothing else has changed!

  5. I think the issue is with the Silicon Labs Multiprotocol Add-On…

    Add-on: Silicon Labs Multiprotocol
    Zigbee and OpenThread multiprotocol add-on
    Add-on version: 2.0.0
    You are running the latest version of this add-on.
    System: Home Assistant OS 10.2 (amd64 / qemux86-64)
    Home Assistant Core: 2023.6.0b3
    Home Assistant Supervisor: 2023.06.0
    Please, share the above information when looking for help
    or support in, e.g., GitHub, forums or the Discord chat.
    It doesn’t give an error, but I’m getting:

    [19:23:58:364149] Info : ENCRYPTION IS DISABLED
    [19:23:58:364150] Info : Starting daemon in normal mode
    [19:23:58:374901] Info : Connecting to Secondary…
    [19:24:00:375104] Info : Failed to connect, secondary seems unresponsive

    Then within Z2M:
    [19:25:52] INFO: Preparing to start…
    [19:25:53] INFO: Socat not enabled
    [19:25:53] INFO: Starting Zigbee2MQTT…
    Zigbee2MQTT:debug 2023-06-02 19:25:55: Loaded state from file /config/zigbee2mqtt/state.json
    Zigbee2MQTT:info 2023-06-02 19:25:55: Logging to console and directory: ‘data/log/2023-06-02.19-25-55’ filename: log.txt
    Zigbee2MQTT:info 2023-06-02 19:25:55: Starting Zigbee2MQTT version 1.31.0 (commit #unknown)
    Zigbee2MQTT:info 2023-06-02 19:25:55: Starting zigbee-herdsman (0.14.117)
    Zigbee2MQTT:debug 2023-06-02 19:25:55: Using zigbee-herdsman with settings: ‘{“adapter”:{“concurrent”:null,”delay”:null,”disableLED”:false},”backupPath”:”/config/zigbee2mqtt/coordinator_backup.json”,”databaseBackupPath”:”/config/zigbee2mqtt/database.db.backup”,”databasePath”:”/config/zigbee2mqtt/database.db”,”network”:{“channelList”:[20],”extendedPanID”:[221,221,221,221,221,221,221,221],”networkKey”:”HIDDEN”,”panID”:6754},”serialPort”:{“adapter”:”ezsp”,”path”:”tcp://core-silabs-multiprotocol:9999″}}’
    Zigbee2MQTT:error 2023-06-02 19:26:16: Error while starting zigbee-herdsman
    Zigbee2MQTT:error 2023-06-02 19:26:16: Failed to start zigbee
    Zigbee2MQTT:error 2023-06-02 19:26:16: Check for possible solutions
    Zigbee2MQTT:error 2023-06-02 19:26:16: Exiting…
    Zigbee2MQTT:error 2023-06-02 19:26:16: Error: Connection not initialized
    at Ezsp.execCommand (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/ezsp.ts:551:19)
    at Ezsp.version (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/ezsp.ts:349:35)
    at Driver.startup (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/driver.ts:141:25)
    at EZSPAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/adapter/ezspAdapter.ts:165:16)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:101:27)
    at start (/app/index.js:107:5)

  6. to bad. can’t install it.
    The driver 2102 is not working for my CH9102 Chip on Dongle E.
    Does anyone has another option?

      • The device is connected. Correctly. After selecting in browser the circle for loading displays and then I get an error that it can‘t be recognised. If I try to install the 210X driver, I get an error from system and it can‘t be detected anymore. Then I flashed the file over xmodem. Now it will be checked but I try to get it work in Hassio.

  7. Can I run two ZBDongle-E’s (on different channels) – my existing one for Zigbee and a new one just for Thread? I don’t want to re-pair all of my Zigbee devices.

      • Thanks. For another $20., it seems silly to time split the radio and possibly worsen response time on my Zigbee mesh.

      • Hi there. Hoping for a little more feedback on this. I am currently using a ZBDongle-P for my Zigbee network. It’s working fine and I really want to avoid having to repair all of my 51 zigbee devices (and all the automations that are associated). But I do want to add Matter/Thread to my HA install. A few questions I’m hoping you can help with:

        1. If I were to get a ZBDongle-E, in the flashing process would I choose “Open Thread” instead of “Multi-Pan”, since I already have a zigbee router?

        2. When connecting it to HA, would I use a different addon other than the Multiprotocol Add-on? (since I’m not using the dongle as a multiprotocol).

        3. If the above isn’t the case, and it needs to be, instead, set up as a border router, can you give any input on how to do that?

        4. Finally, given that I’m only trying to add Matter/Thread, maybe there’s a better alternative than the ZBDongle-E?

        Thanks in advance!

        • Hello,

          1. You can choose Open Thread
          2. The dongle will get autodetected as an Open Thread Border Router via the same Integration
          3. If you need to do it manually, use the Thread integration
          4. So far, the SkyConnect and the ZBDongle-E are the best choices for a thread border router.

          Your suggestion is the better way to do it, as opposed to the multiprotocol add-on.

          • Thanks so much. Really appreciate your responsiveness to the comments in your articles.

            Regarding the SkyConnect, their website says “A future firmware update will bring Thread support; allowing SkyConnect to power your Matter and Zigbee networks at the same time.” Does that mean that the SkyConnect isn’t yet able to act as a matter/thread border router?

          • No, the SkyConnect can be used now as a thread border router using the Multipan firmware.
            You can flash it the same way as the ZBDongle-E.
            However, keep in mind this is all highly experimental and very much in beta stage, so issues are possible and likely.

          • I’ve tried that way and I can’t get it working, I have SkyConnect which is used only for Zigbee (not flashed to multiprotocol firmware) and I’ve flashed ZBDongle-E to Open Thread firmware. The addon isn’t starting up.

  8. Thank you for great article.
    Any suggestion on achieving the same result if I have a separate LXC on Proxmox for Zigbee2MQTT?

  9. Awesome guide!
    But for me, multi pan create unstable network like no response from some devices. Need to tap 5-6 times to have an update state in HA.
    Using ZSP firmware, it’s stable.

  10. Hi,
    i have an existing zigbee network using the Dongle-E.
    What happend with my existing zigbee network after flashing to the MultiPAN protocol?
    Do i need to start from scratch and re-add all devices or is it possible to import a backup for the zigbee network?

    • It didn’t work for me and many other people, so I guess the answer is No.
      A backup successfully restores but the devices are unresponsive.
      Would not hurt to try it though, if you decide you want to flash.

  11. I’m using Homebridge + Zigbee 2 MQTT. Is it possible to install Silicon Labs Multiprotocol directly on Linux?

  12. I’ve been trying to get this working, but when I try to add a device through the mobile app, I get the error, “Thread Border Router Required”. I’ve clicked into the Thread integration, and I see the Border Router projected from Silicon Labs.

      • So I’ve gotten to the point where the websocket is returning a response from postman. So the matter server is receiving requests, but I cant set a thread device. When trying to add a device through the mobile app, the matter addon doesn’t produce any logs. I’m not sure where that add device request is getting gobbled up

      • So I ended up figuring it out, after a lot of debugging. I was running into the “Thread Border Router Required” issue, and noticed that when trying to connect through my phone, the multi-protocol server would log some activity, but nothing in the matter server. I followed the advice here: and decided to postman the request through a websocket.

        I ran into further issues since the websocket connection kicks off a bluetooth connection when trying to pair the thread device. This process did not like my Pi4 internal bluetooth device. I kept getting bluetooth scanning errors in the matter server logs (yay progress). Eventually I figured out if I go into the bluetoothctl and turn on “scan on”, and stay in that shell, the thread device could connect.

  13. Finaly made the jump installed a VM with HA OS and installed the silicon labs addon. after hours of trial and error I have got both thread over matter and zigbee working. however the pairing process seems a lot worse than with my previous combee stick. my aqara device would no pair except for a switch and a water sensor, all the rest will not pair, my hue bulb did pair but not as easy as with the combee.

    I think I will revert to an only zigbee firmware to test, seems instable to me.

  14. Having issues with starting the Zigbee2MQTT
    Can anyone help me how to resolve this issue?

    Here is the log on Zigbee2MQTT:

    [01:14:02] INFO: Preparing to start…
    [01:14:04] INFO: Socat not enabled
    [01:14:10] INFO: Starting Zigbee2MQTT…
    Zigbee2MQTT:info 2023-10-12 01:14:24: Logging to console and directory: ‘/config/zigbee2mqtt/log/2023-10-12.01-14-24’ filename: log.txt
    Zigbee2MQTT:info 2023-10-12 01:14:24: Starting Zigbee2MQTT version 1.33.1 (commit #unknown)
    Zigbee2MQTT:info 2023-10-12 01:14:24: Starting zigbee-herdsman (0.19.0)
    Error: Reset error: Error: {“sequence”:-1} after 10000ms
    at /app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/uart.ts:299:23
    at Queue.executeNext (/app/node_modules/zigbee-herdsman/src/utils/queue.ts:32:32)

    • I am not familiar with this error, although a quick google search told me the first thing to try is to completely shut down the host and replug the dongle.
      Try it and let me know

      • I may be doing something wrong … I just flashed another ZBDongle-E with the router firmware (Z3RouterUSBDonlge_EZNet6.10.3_V1.0.0.gbl) but I can’t add it to ZHA. It does not discovers it…

  15. I don’t get the socket://core-silabs-multiprotocol:9999 options in ZHA integration, only the default /dev/tty. Threads worked as soon as i started the docker container instead.
    Why HA isn’t showing the socket connection?
    HA Core on Debian on Pi4. FW RCP 4.3.2 on Sonoff-E v2

  16. Can a dongle-e be converted to a multiprotocol router? I have a dongle-e used as multiprotocol coordinator and I have a separate Google home as border router. Although the ZigBee mesh is quite good I was thinking to add another dongle-e as a router&border router to cover the back garden and terrace. I didn’t saw any firmware to do that though.

    • You can simply use the guide to flash the OpenThread firmware (not MultiPAN) and the reboot Home Assistant.
      With the dongle plugged in, it will get auto-discovered via the OpenThread Border Router integration.
      Click configure and you are done.

      • Not 4th time lucky. I reflashed the Thread only firmware onto the dongle and still no auto discovery. Now when I click configure it just tells me “no border routers found”. This is atleast different than being asked the URL of the router. I have enabled the beta matter server option. Maybe this explains the change. It has been reset. I changed from a Raspberry Pi 4 USB 3 port to a USB 2 port in case that was somehow effecting things. I know the cable and dongle are okay because I reflashed the fine and the multi-protocol works fine.

        • Please try the following:

          Remove Thread, OpenThreadBorder Router, any HomeKit devices added via Thread.
          Leave the dongle plugged-in and Hard Reboot Home Assistant.

          If it still doesn’t work, install the Silab Multiprotocol Add-on and toggle to ON:
          Enable OpenThread Border Router
          OTBR firewall
          Baud 460800
          Reboot Home Assistant

          • Thanks. I will try when I fully understand. What do you mean by Hard Reboot Home Assistant? Like delete everything and start from blank again or just unpower and repower the device rather than rebooting from the software interface?

          • Hard Reboot means power down the host completely and power it back up.
            You can do it in the developer tools menu.
            Developer Tools > Restart > Advanced Options > Reboot System

  17. I thought that was a standard reboot. I always do this. I followed all suggestions. The configuration settings were already those mentioned. There is no Thread or Open thread integration. I rebooted the Home Assistant. Both with and without the multi-protocol add on running I don’t get auto-discovery. I know the dongle and extension are okay because they work if I put the multi-protocol firmware on it and I have no difficulty connecting to it from Google Chrome on my PC.

  18. Hi,
    My Home Assistant is currently installed via a VM and Zigbee2MQTT is a Docker container on another server to which the dongle is connected.
    How can I make the multiprotocol add-on work with this type of configuration?

    • From the documentation:
      The add-on needs a Silicon Labs based wireless module accessible through a serial port (like the module on Yellow or most USB based wireless adapters).

      Which means, the USB dongle needs to be connected to the host where Home Assistant is running and hosting the Add-on.

  19. Please help!

    I can’t get the flasher to talk with the Sonoff ZBDongle-E
    All I get is:

    “Connection failed
    The running firmware could not be detected.

    Make sure the USB port works and if you are using a USB extension cable, make sure the cable can transfer data. Unplug the Sonoff ZBDongle-E and plug it back in to reset and try again.” The drivers don’t work with it either. 🙁

    • Seems like a USB driver/Port issue.
      Can you try another PC/Laptop to verify?
      Is the ZBDongle detected when used as a coordinator?

      • I tried two computers… My main computer and my macbook air… I requested a new one from them through Amazon thinking it may be defective. The new one just arrived.

  20. Hi,

    I have three Sonoff ZBDongle-E dongles. Initially I planned to have one as a coordinator and flash the other two as router to expand my Zigbee coverage in the house.

    But then I learned that I can flash this Multi-PAN (RCP) firmware to use Zigbee and Matter / Thread at the same time.

    Can I flash the other dongles also to Multi-PAN (RCP) so that they can work as router for Zigbee and Matter / Thread or won’t that work? Or do I need to flash the Zigbee router firmware so that they can least work as router to expand the coverage of the Zigbee mesh?

    • You can, although I would advise against it.
      Since you have three, this is how I would flash them:
      1. Zigbee Coordinator
      2. Zigbee Router
      3. Open Thread Border Router

      You only need MultiPAN for Thread, the rest can be flashed with their official firmware to act as routers/coordinators.


  21. Thanks for your answer/proposal.

    The initial idea was to have one dongle on ground level (coordinator). That will be directly connected to Home Assistant.

    The second dongle should be on the first floor to cover the devices there and a third dongle on the second floor to cover the devices there.

    Would that work with your proposal with the 3 different roles / firmwares?

    • Now that you’ve provided more info, here’s how I would create a really solid Zigbee mesh network in your situation:

      1. Ground floor: Zigbee coordinator (Sonoff)
      2. Second floor: Zigbee router (Sonoff)
      3. Third floor: Zigbee repeater (LoraTap or similar from AliExpress)

      The Loratap Zigbee repeaters are simple plug and play USB dongles whose sole function is to extend and solidify your mesh network.
      These dedicated Zigbee routers/range extenders/signal repeaters are essentially the same thing. Their sole purpose is to create better paths to your coordinator for your other devices.

      Zigbee routers can also be mains power (N+L) connected things like plugs, switches, presence sensors, so you could also use these create a more stable network.

      The main difference is, not all Zigbee routers will talk with other devices in their vicinity (Aqara is known to problematic in this sense). Whereas, dedicated Zigbee repeaters will talk with any and every device that requests a better path to your coordinator.

      Here’s the LoraTap model I mentioned:
      Here’s my review with alternative links:

      For Thread, I would place the third Sonoff flashed with OpenThread firmware wherever you have the most Thread devices and work from there.
      I do not think you will ever need another Thread border router, since Thread is more powerful than Zigbee (this claim remains to be proven!)

      I hope this is helpful,

  22. Great! Thanks again for your detailed explanation and suggestion. I will do it exactly who you described it. 😉

    • Zigbe2MQTT cannot reach your coordinator.
      You either have an error in the Silabs Multiprotocol Add-on configuration or the USB port is inaccessible?
      Is something else using the Dongle (besides OpenThread)?
      Restart Home Assistant after making any changes.

Comments are closed.